DIY ATEM Arduino Controller - Reconnecting issue

2 posts / 0 new
Last post
Offline

Location

Kristianstad
Sweden
Joined: 12/12/2016
Posts: 18
DIY ATEM Arduino Controller - Reconnecting issue

Seem to be having a head scracther of an issues with my custom build ATEM ardunio. Here's a few important facts:

- Connecting to a HD ATEM 1M/E
- Using a genuine Arduino and Ethernet Shield
- Using the newest version of ATEMmin

For some reason the arduino looses connection (at around rpID:52 almost every time) and then fails to reconnect, but continues to try.

I also tried connecting directly to the ATEM but with no luck at all (wasn't even able to find a connection).

Is this a known issue for anyone?

Many thanks!

John Barker
heretorecord.com

Check out my gear-focused YouTube Series right here!

Offline

Location

Leeds
United Kingdom
Joined: 12/07/2015
Posts: 81
Have you tried one of the

Have you tried one of the example projects? That way you could tell if it's your code or something else. Either way, upload your code somewhere and we'll try and diagnose the issue. One thing to check that catches people out is that you can't use the standard "delay" function as it stops talking to the ATEM during the delay and the connection is lost. 

 

 

ATEM 2 M/E 4K, ATEM 1 M/E 4K, HyperDeck Studio Pro 4K, DeckLink Mini Recorder

Custom SKAARHOJ based controller