Latest drivers to use with an Atom CPU based Windows PC?

8 posts / 0 new
Last post
Offline

Location

Lichfield,
United Kingdom
Joined: 28/07/2014
Posts: 5
Latest drivers to use with an Atom CPU based Windows PC?

I wonder if a member would be kind enough to assist me?
I use a TVS for a wide variety of work, ranging from very simple two camera portable switching to multicamera switching with several PC’s doing various functions. In general this works great and I have just purchased an Asus Eeebook notebook specifically to use for the simplest jobs to use rather than a Macbook. The Asus is minimal spec, but does have great battery life and because the notebook will only be used to switch I’m hoping it will be adequate. It does not have a LAN port, but I have resolved this with a USB to LAN convertor. When using the TVS previously with various PC’s and Macs we have updated the drivers regularly and was running the latest drivers which are great (love the macros but probably won’t use them very often). However, the notepad won’t install the latest drivers (unsuitable CPU message - Atom) but happily installed the earliest drivers I have to hand (v4.0) and I’ve rolled back the TVS to this. Everything seems to be working OK within the limitations of those drivers. I would like to run the latest drivers possible but would be very happy if anyone can help me by suggesting which drivers will work, saving me having to progressively work through them!
Also, is there any harm in flashing the TVS very often? The other option is to change the TVS firmware to and from early/latest drivers depending on what the device is being used for.
Thanks in advance.

Asus Eeebook X205TA  Spec:
Windows 8.1, 32 bit (the problem?)
Quadcore Atom Z3735
2GB RAM
SSD Hard disc.
11.6" 1366 x 768 display.

Offline

Location

Cornwall,
United Kingdom
Joined: 11/08/2014
Posts: 284
I think using 32bit you

I think using 32bit you should be able to run up to 6.0 maybe 6.1 I'm not exactly sure where the swap was made, but it was around that time.

A.

Offline

Location

Auckland,
New Zealand
Joined: 14/07/2011
Posts: 28
6.1.1 Definitely worked -

6.1.1 Definitely worked - newer versions no such luck. Kinda sucks as I bought a cheap HP Slate to be a second option for control.

Offline

Location

Lichfield,
United Kingdom
Joined: 28/07/2014
Posts: 5
Yes 6.1.1 seems OK

Thanks for the speedy replies.
6.1.1 seems to be OK. I need to give it an extended real life test, but a quick test seems to have it working fine and I should be able to stick to this for all scenarios, saving me from having to keep flashing the firmware.
Thanks for your help.

Offline

Location

Morava
Czech Republic
Joined: 02/01/2015
Posts: 8
Where to find 6.1.1

I have the same problem, I would like to use TVS with Asus T100TA with a touchscreen, but it has 32bit windows. Is it possible to download version 6.1.1 somewhere? Thanks

Offline

Location

Cornwall,
United Kingdom
Joined: 11/08/2014
Posts: 284
https://www.blackmagicdesign.

https://www.blackmagicdesign.com/support/family/atem-live-production-swi...

Scroll down the menu panel in bottom left corner of the above webpage.

A.

Offline

Location

Morava
Czech Republic
Joined: 02/01/2015
Posts: 8
6.1.1 to 6.4

Thanks, I overlooked that there are old updates.

I made an experiment. I installed 6.1.1 on 32bit Windows (Asus T100TA) and new 6.4 on computer with 64bit Windows. From computer with 6.4 copied all files from folder "C:\Program Files (x86)\Blackmagic Design\Blackmagic ATEM Switchers" to 6.1.1 folder "C:\Program Files\Blackmagic Design\Blackmagic ATEM Switchers" on 32bit Win. Software control shows warning on start (some missing components), but it works!
I am not understand BMD - it is obvious that it is 32bit app, but installer requires 64bit system.

Offline

Location

Lichfield,
United Kingdom
Joined: 28/07/2014
Posts: 5
I'm not sure if I should laugh or cry!

It works for me which is brilliant, but a bit frustrating.
I can now have a portable PC (running 32 bit) and my other PC's all running the same, 6.4 divers and will not have to mess about flashing the TVS back and forth depending on which is being used.
I've not had time to do an extensive test but it seems to work fine. It's a bit annoying that BMD didn't sort this.
Many thanks Mart.